Error: Cannot satisfy dependencies

rlg
Posts: 6
Joined: Thu Mar 26, 2020 9:39 pm

Error: Cannot satisfy dependencies

Post by rlg »

I am trying to install DDRescue-GUI on Ubuntu 19.10 and I get the error Cannot satisfy dependencies.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Error: Cannot satisfy dependencies

Post by hamishmb »

Sounds like you need to install GetDevInfo first (https://www.hamishmb.com/html/downloads.php?program_name=getdevinfo)

rlg
Posts: 6
Joined: Thu Mar 26, 2020 9:39 pm

Re: Error: Cannot satisfy dependencies

Post by rlg »

I did that. I tried again with the same results.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Error: Cannot satisfy dependencies

Post by hamishmb »

Okay, can you give me the full error message then please?

Note that You'll need the Python 3 version of GetDevInfo

rlg
Posts: 6
Joined: Thu Mar 26, 2020 9:39 pm

Re: Error: Cannot satisfy dependencies

Post by rlg »

I am using the Python 3 version, downloaded from your site. The exact message I get when clicking on the downloaded file is in a pop up box that says:
Package Installer
Package: ddrescue-gui
Status: Error: Cannot satisfy dependencies

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Error: Cannot satisfy dependencies

Post by hamishmb »

Okay. What distribution and version are you using? I can give you a command to run which will give me more information as to what the problem is, but I'll need to know what distribution you're using first.

rlg
Posts: 6
Joined: Thu Mar 26, 2020 9:39 pm

Re: Error: Cannot satisfy dependencies

Post by rlg »

I'm using Ubuntu (Kubuntu) 19.10

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Error: Cannot satisfy dependencies

Post by hamishmb »

Okay. Could you open a Terminal (Konsole), change directory to the folder you saved DDRescue-GUI in and run:

sudo apt install ./<package-name>

ANd paste the output here please?

rlg
Posts: 6
Joined: Thu Mar 26, 2020 9:39 pm

Re: Error: Cannot satisfy dependencies

Post by rlg »

[email protected]:/home/rlg/Downloads 8647$ sudo apt install ./ddrescue-gui_2.0.2_bionic-0ubuntu1_ppa1_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'ddrescue-gui' instead of './ddrescue-gui_2.0.2_bionic-0ubuntu1_ppa1_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ddrescue-gui : Depends: python3.6 but it is not installable
E: Unable to correct problems, you have held broken packages.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Error: Cannot satisfy dependencies

Post by hamishmb »

Thanks.

The output suggests that you've got my PPA added, but for the wrong version of Ubuntu - you might need to use software sources to verify this. Also, you should be using the DDRescue-GUI v2.1.0 package for Ubuntu 16.04 or newer at https://www.hamishmb.com/html/downloads.php?program_name=ddrescue-gui.

Hope this helps,
Hamish

Post Reply