Getting 'Unsuported ddrescue version' after update ddrescue

Post Reply
fran
Posts: 1
Joined: Tue Mar 03, 2020 1:18 pm

Getting 'Unsuported ddrescue version' after update ddrescue

Post by fran »

Hi.

I'm running DDRescue-GUI in ArchLinux (maybe relevant) and I'm trying to recover a NTFS partition (irrelevant, I thik).
There are some features that apparently fails:
Getting Disk Info -a void list is shown-.
Trying to mount img file after stop process raise a loop of 'enter root password' until I kill app.
Anyway the core process seems ok. I'm been recovering data for a few days whit ddrescue-gui. All goes ok -or so I think since I'm be able to recover some test file from image with testdisk-.

But last system update upgraded ddrescue from 1.24-2 to 1.25-1. Now DDRescue-GUI alerts about unsuported ddrescue version but DDRescue-GUI is up to date.

It's safe to resume data recovering with this newer version of ddrescue?

Thanks in advance.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Getting 'Unsuported ddrescue version' after update ddrescue

Post by hamishmb »

It should be, you may just experience some formatting issues until I update the GUI.

It should be fine, but I haven't tested that version of ddrescue with the GUI yet (I wasn't aware it had been released yet), so your mileage may vary.

Personally, I'd recommend using 1.24 unless you have a reason not to.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Getting 'Unsuported ddrescue version' after update ddrescue

Post by hamishmb »

I have tested DDRescue-GUI and can confirm that it works with GNU ddrescue 1.25. You'll still get a warning until the next release, but you can disregard it :)

fran2
Posts: 1
Joined: Thu Mar 12, 2020 4:26 pm

Re: Getting 'Unsuported ddrescue version' after update ddrescue

Post by fran2 »

Hi,
I've opted for a conservative strategy, as you point in your first post, so I dowgraded ddrescue package to 1.24.

The main reason is ddrescue version itself instead of DDRescue-GUI, because I'm not sure if it is safe to work over the same img file with two different versions of ddrescue.
From the view of the changelog for 1.25 I wolud bet 'yes'...but also I can lost the work of too many days, and I don't have disks for save many copies. of 1TB..
Since I've not been able to find a trust source for confirm whether it's safe or not, I will try to end recovering with ddrescue 1.24.

Thanks a lot for your reply!

Best regards.

hamishmb
Site Admin
Posts: 56
Joined: Sun Oct 28, 2018 10:47 am
Contact:

Re: Getting 'Unsuported ddrescue version' after update ddrescue

Post by hamishmb »

From what I understand, not much has changed in ddrescue 1.25, so it should be fine.

If you haven't already, make a backup of your log file just in case though :)

Glad I could be of use.

Post Reply