Installing DDRescue-GUI 2.0.2 on Debian Stretch

Please note that without extra packages it is not possible to install DDRescue-GUI 2.1.0 and later versions on Debian Stretch.

Instructions

As wxPython 4 for Python 3 is not available on Debian Stretch, we need to use Python 2.

First head to https://www.hamishmb.com/html/museum.php?program_name=getdevinfo#v1.0.6 and download the Python 2 version of GetDevInfo for Ubuntu 16.04.

Next head to https://www.hamishmb.com/html/museum.php?program_name=ddrescue-gui#v2.0.2 and download the version of DDRescue-GUI listed as for “Ubuntu 14.04 – 16.04”. This is the Python 2 version.

Next, navigate to the folder where you saved these in the Terminal (CTRL + ALT + T), and install the packages with:

sudo apt-get install ./python-getdevinfo_1.0.6~xenial-0ubuntu1~ppa1_all.deb
sudo apt-get install ./ddrescue-gui_2.0.2~trusty-0ubuntu1~ppa1_all.deb

Apt should download and install all the dependencies for you, and you should now have a slightly older but still useful version of DDRescue-GUI on your installation.

Leave a Reply

Your email address will not be published.